Gistをeditすると古いバージョンへのリンクがリンク切れになってしまい、
そのたびにリンク貼り替えるのは面倒だなぁと思っていたのだけど、
なんのことはないURLを「最新版へのリンク」にしておけばよいのよね。


それを知らなくて今まではGreasemonkeyインストール用のURLをこんなのにしてたけど、

https://gist.github.com/raw/614547/c54b4589d2fb9305f9e9ac2f0f75836a09008792/tumblr_queue_latest_link.user.js

そうではなくて最新版のリンク、こんなのにすればリンク切れが起きる心配がない。

https://gist.github.com/raw/614547/tumblr_queue_latest_link.user.js

また、gistに含まれるファイルが1つだけの場合には、これでも行ける。
(ただし、拡張子が「user.js」ではないのでGreaseMonkeyとしてインストールは出来ない)

https://gist.github.com/raw/614547


おおう。

Greasemonkeyのインストール用URLをちょっと修正して回らなければ。


参考

Gist の raw ファイルの URL が変わった: 「わ」の日記もどき