サイトにアクセスしたらこういうエラーが出てました。

Warning: require_once(HTTP/Client.php) [function.require-once]: failed to open stream: No such file or directory in ***

おいそんなわけないだろと思ったんですが、調べてみると、
phpのディレクトリ名が変更になった模様。

php-5.2.5 → php-5.2.6
php.iniの環境変数には、/usr/local/php-5.2.5/lib/phpを登録していたので、
それがディレクトリ名の変更で無効になってエラーが出た模様…そんなんありなのか。
同じディレクトリにあるphp(シンボリックリンク)が、php-4.4.7を参照しているので、
仕方が無くバージョン名を含んだディレクトリを参照してたんだけど。

この『php+バージョン』っていうディレクトリ名の付け方が、
どれくらい一般的かよくわからないけど、ディレクトリ名の変更に左右されないように、
モジュールを参照させるにはどうしたらいいのか、全くわからん。
ローカルに入れた方が良いのかなぁ?



ちなみにシンボリックリンクのphpの方も、php4のディレクトリが、

php-4.4.7 → php-4.4.8

に変更になっているにもかかわらずシンボリックリンクは更新されていないので、
機能してません。
(機能してれば、php-4.4.8以下のHTTP/Client.phpが呼び出されてるはず)

ええー。



なんかもうよくわからんけど、良い手ないもんかなぁ。
バージョンアップする毎にエラーとか意味わからんし。

モジュールは、ローカルにコピーして使った方が良いかもね。もしかして。